Measuremen Portal: Translations issue
Incident Report for Measuremen
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 15:06 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2024 - 10:08 CET
Investigating
We are currently investigating the issue where translations to languages other than English are not consistently being translated.
Posted Mar 19, 2024 - 09:48 CET
This incident affected: Measuremen Portal.