Measuremen Portal - iBASX dashboards unavailable

Incident Report for Measuremen

Resolved

This incident has been resolved and all impacted iBASX dashboards have returned to full functionality with new data being loaded in as expected.
Apologies for the inconveniences caused.
Posted Dec 11, 2025 - 13:42 CET

Identified

We are currently adressing an issue affecting our iBASX solution. All iBASX dashboards are impacted and are not operational at this time.
We will provide updates as soon as more information is available.
Posted Dec 11, 2025 - 13:15 CET
This incident affected: Measuremen Portal.