Measuremen Portal - Loading time
Incident Report for Measuremen
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 08:46 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2024 - 17:35 CET
Investigating
We are currently investigating an issue where it is possible to experience degraded performance on our Measuremen Portal. This issue occurs very situational and should not impact the majority of your usage.
Posted Mar 06, 2024 - 16:26 CET
This incident affected: Measuremen Portal.